Open-AudIT

What's on your network?
It is currently Wed Apr 25, 2018 10:14 pm

All times are UTC + 10 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Thu Apr 14, 2016 3:38 am 
Offline
Newbie

Joined: Fri Jan 29, 2016 12:52 am
Posts: 14
Hello,

Windows 7 Enterprise client, Open-Audit server on Windows 10.

When I do a Device Discovery from the website, it will find the client, update the last seen time, but does not update the installed software.

When I do a Audit My Computer from the client, everything works fine.

I have worked through the Client Configuration steps and everything seems to be OK. Are there similar steps for configuring the server?

I'm at a loss at the moment. Any suggestions are appreciated.

Alan


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 14, 2016 6:18 am 
Offline
Moderator

Joined: Fri Jul 20, 2007 8:27 am
Posts: 1254
Anything obvious if you select the Debug check box on the "Discover a Windows computer" page?


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 14, 2016 6:25 am 
Offline
Newbie

Joined: Fri Jan 29, 2016 12:52 am
Posts: 14
Hmmmm...I'm getting a bunch of php errors like this:

DEBUG ---------------
LOG - WMIC supplied credentials for 192.168.1.81 succeeded

LOG - WMIC command 'csproduct get uuid' on 192.168.1.81 succeeded

DEBUG - Command Executed: %comspec% /c start /b wmic /Node:"192.168.1.81" /user:WRK-0011\Administrator /password:"[REMOVED]" csproduct get uuid
DEBUG - Return Value: 0
DEBUG - Command Output:
Array
(
)

DEBUG ---------------


A PHP Error was encountered


Severity: Notice


Message: Undefined offset: 1


Filename: controllers/discovery.php


Line Number: 1323


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 14, 2016 8:40 am 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1944
Location: Brisbane, Australia
First suggestion is always to make sure you're running the newest code. As at time of posting 1.12.4 is out. Please update to this if possible.

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 15, 2016 3:16 am 
Offline
Newbie

Joined: Fri Jan 29, 2016 12:52 am
Posts: 14
Hi Mark,

I've updated to the latest and greatest with the same result. Are the PHP errors in the debug log significant?

Any other suggestions?

Thanks!
Alan


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 15, 2016 3:39 am 
Offline
Moderator

Joined: Fri Jul 20, 2007 8:27 am
Posts: 1254
Could you post the debug output again from the latest version? Then I can check the error line number to take a guess at the problem or ask for further info.


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 15, 2016 4:05 am 
Offline
Newbie

Joined: Fri Jan 29, 2016 12:52 am
Posts: 14
Hi Mark,

I have solved this - long story short: it was a firewall rule on the client.

One of the firewall rules you recommend in your client setup guide doesn't work in Win7:

netsh advfirewall firewall set rule group="remote administration" new enable=yes

Needs to be:

netsh firewall set service type=remoteadmin mode=enable

Things seem to be working great so far. Thanks again!

Alan


Top
 Profile  
Reply with quote  
PostPosted: Mon Apr 18, 2016 11:06 am 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1944
Location: Brisbane, Australia
Thanks Alan, I have updated the documentation.

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group