Open-AudIT
https://www.open-audit.org/phpBB3/

Upgrade from 1.12 to 2.2.7 (Windows)
https://www.open-audit.org/phpBB3/viewtopic.php?f=20&t=6688
Page 1 of 1

Author:  captaincrash0815 [ Thu Oct 18, 2018 8:39 pm ]
Post subject:  Upgrade from 1.12 to 2.2.7 (Windows)

Hello,

how it is possbile to upgrade from Version 1.12 to the 2.2.7 open audit version (with database!!!)

We exported the old database. Then we installed the newest version on a new host and use the old database.
At the start, we get the webpage with an database upgrade button. We click on the button and a few minutes later we get an error message:

Quote:
A Database Error Occurred

Error Number: 1075
Incorrect table definition; there can be only one auto column and it must be defined as a key
ALTER TABLE `system` DROP KEY system_id
Filename: C:\xampplite\open-audit\code_igniter\system\database\DB_driver.php
Line Number: 330



Please Help

Attachments:
Unbenannt.png
Unbenannt.png [ 21.31 KiB | Viewed 711 times ]

Author:  Mark [ Tue Oct 30, 2018 9:27 am ]
Post subject:  Re: Upgrade from 1.12 to 2.2.7 (Windows)

Absolutely no promises on this working or not breaking the DB (so make SURE you backup your DB first, see below), but you could try commenting out line 626 in /open-audit/code_igniter/application/controllers/db_upgrades/db_1.14.04.php, then re-running the upgrade from the web GUI.
Backup commands below. Note if you're on Windows, you'll need to run them from c:\xampplite\mysql\bin
Code:
mysql -u openaudit -popenauditpassword -e "DELETE FROM oa_user_sessions;"
mysqldump -u openaudit -popenauditpassword --extended-insert=FALSE --routines openaudit > openaudit_mysql_backup.sql

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/