Open-AudIT
https://www.open-audit.org/phpBB3/

v2.0.2 Create Query
https://www.open-audit.org/phpBB3/viewtopic.php?f=20&t=6613
Page 1 of 1

Author:  jainsworth [ Tue Aug 08, 2017 7:05 am ]
Post subject:  v2.0.2 Create Query

I am trying to create a custom query on a fresh install of this version. I can run the SQL and the query is valid, but when I go through the "create query" page, and click submit, I never see the query appear. Is there something else I need to do?

Here is the query. I took an existing query and wanted some additional information.

SELECT system.id AS `system.id`,
system.icon AS `system.icon`,
system.type AS `system.type`,
system.name AS `system.name`,
system.domain AS `system.domain`,
system.ip AS `system.ip`,
system.manufacturer AS `system.manufacturer`,
system.model AS `system.model`,
system.serial AS `system.serial`,
system.os_family AS `system.os_family`,
system.memory_count AS `system.memory_count`,
system.form_factor AS `system.form_factor`,
processor.description AS `processor.description`,
system.processor_count AS 'system.processor_count',
disk.manufacturer AS 'disk.manufacturer',
disk.model AS 'disk.model',
disk.serial AS 'disk.serial',
disk.size AS 'disk.size',
network.mac AS 'network.mac',
network.manufacturer AS 'network.manufacturer',
network.model AS 'network.model',
sound.manufacturer AS 'sound.manufacturer',
sound.model AS 'sound.model',
user.name AS 'user.name',
user.full_name AS 'user.full_name',
video.manufacturer AS 'video.manufacturer',
video.model AS 'video.model',
video.size AS 'video.size'
FROM system
LEFT JOIN processor ON (processor.system_id = system.id AND processor.current = 'y')
LEFT JOIN network ON (network.system_id = system.id AND network.current = 'y')
LEFT JOIN disk ON (disk.system_id = system.id AND disk.current = 'y')
LEFT JOIN sound ON (sound.system_id = system.id AND sound.current = 'y')
LEFT JOIN user ON (user.system_id = system.id AND user.current = 'y')
LEFT JOIN video ON (video.system_id = system.id AND video.current = 'y')
WHERE @filter ORDER BY system.name

Author:  jpa [ Wed Aug 09, 2017 8:28 am ]
Post subject:  Re: v2.0.2 Create Query

Yes, a little bit broken. If you want to fix it yourself before Opmantek gets to it.

Edit \code_igniter\application\views\theme-bootstrap\v_queries_create_form.php and change:

Line 37 from
Code:
<form class="form-horizontal" id="form_update" method="post" action="<?php echo $this->response->meta->collection; ?>">
to
Code:
<form class="form-horizontal" id="form_update" method="post" action="<?php echo $this->response->links->self; ?>">


Line 73 from
Code:
<label for="data[attributes][menu_category]" class="col-sm-4 control-label"><%== l($human_column) %></label>
to
Code:
<label for="data[attributes][menu_category]" class="col-sm-4 control-label">Menu Category</label>

Author:  Mark [ Wed Aug 09, 2017 11:21 am ]
Post subject:  Re: v2.0.2 Create Query

FYI - this is fixed for the next release.

Author:  jainsworth [ Thu Aug 10, 2017 1:05 am ]
Post subject:  Re: v2.0.2 Create Query

Thank you both!

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/