1.12.6 from 1.8.4
Page 1 of 1

Author:  jbias [ Thu May 26, 2016 5:07 am ]
Post subject:  1.12.6 from 1.8.4

Installed 1.12.6, logged into OA and got the DB upgrade prompt, I let it run until the page stopped running (running Chrome 50.0.2661.102). Logged into OA again and had the DB upgrade prompt. tried firing it off again and getting:

A Database Error Occurred

Error Number: 1146

Table 'openaudit.sys_hw_bios' doesn't exist

DELETE sys_hw_bios FROM sys_hw_bios LEFT JOIN system ON system.system_id = sys_hw_bios.system_id WHERE sys_hw_bios.timestamp <> system.timestamp

Filename: C:\xampplite\open-audit\code_igniter\system\database\DB_driver.php

Line Number: 330

Assuming this is hosed? If I have to restart from scratch it's not that critical since this is more of a rogue application at this point. But I'd still like to recover if I can. And no, no backup. :D

Author:  jpa [ Thu May 26, 2016 7:34 am ]
Post subject:  Re: 1.12.6 from 1.8.4

My money is on hosed but you're probably in luck as OpenAudit 1.12.6 on Windows is supposed to take a backup before upgrading.

The release announcement has this:
The Windows installer now creates a backup of the database before upgrading. So if you see a large disk use increase, check the folder c:\xampplite\open-auditXXXXXXXXX where X is the datestamp. In that folder you'll find a .sql file which should zip quite nicely if you need to save space. Please do not delete it as it is a backup which you can restore from if everything goes pear shaped.

Author:  Mark [ Thu May 26, 2016 12:36 pm ]
Post subject:  Re: 1.12.6 from 1.8.4

I actually found this yesterday and have fixed it.
Restore your database, download 1.12.6_1 and run it.
It should "just work".

FYI - this happens because you're upgrading from an older version and the new version has a new SQL schema, which is reflected in the new group definitions. Unfortunately we attempt to refresh the default groups in a previous upgrade. IE - before the SQL schema change has taken effect. Hence the break. In 1.12.6_1 I have moved the group and report definition refreshes out of the individual version upgrades and to the end of the upgrade (as a whole) function. Hence they only get run after all database stuff has been taken care of.


Author:  jbias [ Wed Jun 01, 2016 5:18 am ]
Post subject:  Re: 1.12.6 from 1.8.4

Thanks guys

Still no love. Dropped the tables and restored the DB, install the new rev, I have to hit the DB upgrade routine again and it pretty much repeats the process with the same error.

Can I do stepped upgrade from a previous version first?

Author:  jpa [ Wed Jun 01, 2016 12:21 pm ]
Post subject:  Re: 1.12.6 from 1.8.4


Clean up the existing database a bit by using the database maintenance to remove unneeded notifications and such.

Check PHP timeouts. I don't use the standard install so I'm not sure how they're set.

Try to figure out how far it's getting in the upgrade process by checking the upgrade function in controllers\admin.php to see how far it's getting and what it's likely getting stuck on. Not an easy task if you're not familiar with databases.

Hopefully Mark has better ideas.

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group