Registrations to Open-AudIT forums are now closed. To ask any new questions please visit Opmantek Community Questions.


What's on your network?
It is currently Thu Aug 18, 2022 9:35 am

All times are UTC + 10 hours

Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 
Author Message
PostPosted: Wed Feb 17, 2016 7:47 pm 

Joined: Wed Feb 17, 2016 12:17 am
Posts: 2

I've run into problems upgrading from 1.8.4 to 1.12. Hope someone can help please ?

I downloaded the update (Windows), ran it on the server. All went OK. Logged onto OpenAudit and updated the database, no problems reported.

I then edited the new audit_windows.vbs script and tried it on my workstation, but it reports the following error when trying to upload to the server

<div id="container">
<h1>A Database Error Occurred</h1>
<p>Error Number: 1146</p><p>Table 'openaudit.sys_sw_software' do
esn't exist</p><p>SELECT system_id FROM system WHERE system_id = '1' AND system_
id in ( SELECT distinct(system.system_id) FROM sys_sw_software, system WHERE sys
_sw_software.system_id = system.system_id AND software_name LIKE '%Mozilla Firef
ox%' AND system.man_status = 'production' AND sys_sw_software.timestamp = system
.timestamp )</p><p>Filename: C:\xampplite\open-audit\code_igniter\system\databas
e\DB_driver.php</p><p>Line Number: 330</p> </div>

I started to check through what else might be broken and came across some weird problems.

1) Many groups are broken - but a lot of these have been customised and the database schema has changed and I was querying on tables that no longer exist, fair enough. Then I came across a group that worked OK, but it was querying sys_sw_software, the table that the error above says doesn't exist. I took a copy of the XML for the group that worked and tried to import it again with a different name - it errored and said that sys_sw_software doesn't exist. But the original group still works..........????

2) I went to Admin, Groups, Add Group and checked to see what tables were available in the Group Selection menu. Only the following are showing

3) Checked the database schema by going to Admin, Database, Export a Database Table. I can see all the renamed tables such as bios, disk, memory, software etc, but many of them seem to be inaccessible. If I try to export them I receive a Page Can't Be Displayed error (software being one of those that is broken)

Can anyone help please ? I didn't spot any specific upgrade procedures in the release notes and this method has always worked before. Can it be rescued, or am I going to have to restore the virtual machine from backup


Reply with quote  
PostPosted: Wed Feb 17, 2016 10:01 pm 
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1964
Location: Brisbane, Australia
Hi Stephen,

Everything you've posted sounds as it should be - with the exception of the table export. I'll look into that. UPDATE, just checked and I can export the tables just fine.

Admin -> Groups -> Add Group is definitely broken though. Thanks for reporting it. I'll ensure it's fixed for the next release.

sys_sw_software has indeed been renamed to software (as have the others you've found).

I have replaced all group and report definitions that ship with Open-AudIT and yours should have been replaced by the upgrade procedure. Any custom groups or reports will not have been upgraded and you should have seen a message when you updated the DB.

This was all covered in the release notes - [url][/url].

We should definitely be able to rescue this. Absolute worst case - ship me a copy of the DB and I'll fix it by hand. But let's cross that bridge only if we need to :-)

Support and Development hours available from [url=]Opmantek[/url].
Please consider a purchase to help make Open-AudIT better for everyone.

Reply with quote  
PostPosted: Wed Feb 17, 2016 10:11 pm 

Joined: Wed Feb 17, 2016 12:17 am
Posts: 2
Thanks Mark - After I posted this I had to run a restore as I needed OpenAudit back, but I restored the VM as a copy, so the broken upgrade is still there, but currently shutdown.

Sounds like I will need to wait until the next release as we use the group admin wizard quite a bit. Next time I will keep a copy of the database update report as it sounds like something went wrong that I missed.

I'll see what happens when I next upgrade


Reply with quote  
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 

All times are UTC + 10 hours

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group