Open-AudIT
https://www.open-audit.org/phpBB3/

Query Specific OU error
https://www.open-audit.org/phpBB3/viewtopic.php?f=20&t=6422
Page 1 of 1

Author:  omega4471 [ Thu Mar 26, 2015 7:31 pm ]
Post subject:  Query Specific OU error

OA 1.6.2

The query Specific OU show this error after clicking on OU:

-----------------------------------------------------------
A PHP Error was encountered

Severity: Notice

Message: Undefined property: stdClass::$man_type

Filename: theme-tango/v_report.php

Line Number: 153
--------------------------------------------------------------
After this error the PC are listed.


How can i fix it?
Thanks

Author:  Mark [ Fri Mar 27, 2015 11:05 am ]
Post subject:  Re: Query Specific OU error

Hi Omega,

Looks like an issue with the report definition. Import the below and it should hopefully be fixed. FYI - I added man_type to the report_sql field.

This will be included in the next release.

First remove the old query by menu -> Admin -> Queries -> List Queries and clicking the X icon.
Import the new query by copying the below and pasting it into the textbox at menu -> Admin -> Queries -> Import Query.

Mark.

Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<report>
   <details>
      <report_name>Specific OU</report_name>
      <report_display_in_menu>n</report_display_in_menu>
      <report_sql><![CDATA[SELECT man_icon, hostname, system.system_id as system_id, man_model, man_owner, man_type, org_name, location_name FROM system LEFT JOIN oa_group_sys ON system.system_id = oa_group_sys.system_id LEFT JOIN sys_sw_windows ON (system.system_id = sys_sw_windows.system_id AND system.timestamp = sys_sw_windows.timestamp) LEFT JOIN oa_org ON system.man_org_id = oa_org.org_id LEFT JOIN oa_location ON system.man_location_id = oa_location.location_id WHERE oa_group_sys.group_id = @group AND sys_sw_windows.windows_active_directory_ou = (SELECT windows_active_directory_ou FROM sys_sw_windows WHERE windows_id = ?)]]></report_sql>
      <report_view_file>v_report</report_view_file>
      <report_view_contents></report_view_contents>
      <report_processing></report_processing>
      <report_sort_column>0</report_sort_column>
      <report_description>Devices in a specific Active Directory OU.</report_description>
   </details>
   <columns>
      <column>
         <column_order>0</column_order>
         <column_name>Icon</column_name>
         <column_variable>man_icon</column_variable>
         <column_type>image</column_type>
         <column_link></column_link>
         <column_secondary>man_type</column_secondary>
         <column_ternary></column_ternary>
         <column_align>center</column_align>
      </column>
      <column>
         <column_order>1</column_order>
         <column_name>System Name</column_name>
         <column_variable>hostname</column_variable>
         <column_type>link</column_type>
         <column_link>/main/system_display/</column_link>
         <column_secondary>system_id</column_secondary>
         <column_ternary></column_ternary>
         <column_align>left</column_align>
      </column>
      <column>
         <column_order>2</column_order>
         <column_name>Model</column_name>
         <column_variable>man_model</column_variable>
         <column_type>text</column_type>
         <column_link></column_link>
         <column_secondary></column_secondary>
         <column_ternary></column_ternary>
         <column_align>left</column_align>
      </column>
      <column>
         <column_order>3</column_order>
         <column_name>Assigned To</column_name>
         <column_variable>man_owner</column_variable>
         <column_type>text</column_type>
         <column_link></column_link>
         <column_secondary></column_secondary>
         <column_ternary></column_ternary>
         <column_align>left</column_align>
      </column>
      <column>
         <column_order>4</column_order>
         <column_name>Organisation</column_name>
         <column_variable>org_name</column_variable>
         <column_type>text</column_type>
         <column_link></column_link>
         <column_secondary></column_secondary>
         <column_ternary></column_ternary>
         <column_align>left</column_align>
      </column>
      <column>
         <column_order>5</column_order>
         <column_name>Location</column_name>
         <column_variable>location_name</column_variable>
         <column_type>text</column_type>
         <column_link></column_link>
         <column_secondary></column_secondary>
         <column_ternary></column_ternary>
         <column_align>left</column_align>
      </column>
      <column>
         <column_order>6</column_order>
         <column_name>Tags</column_name>
         <column_variable>tag</column_variable>
         <column_type>text</column_type>
         <column_link></column_link>
         <column_secondary></column_secondary>
         <column_ternary></column_ternary>
         <column_align>center</column_align>
      </column>
   </columns>
</report>

Author:  omega4471 [ Fri Mar 27, 2015 8:20 pm ]
Post subject:  Re: Query Specific OU error

works perfectly!!
thank you very much
Frank

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/