Just starting... can't get new users added
Page 1 of 1

Author:  jfr [ Fri Feb 14, 2014 9:33 am ]
Post subject:  Just starting... can't get new users added

Hi, I have just installed Open-audIT on Ubuntu 13.10 with the standard MySQL installation, etc. I got through the whole installation, and everything looks good. Inside MySQL I can see the openaudit database, the oa_user table has three users (admin, open-audit_enterprise and nmis) each with what appears to be a scrambled password (although not what the password() function in MySQL appears to provide so I am assuming it does its own scrambing under to covers.

The very first thing I tried to do was change the admin password which is by default "password". I opened the List Users menu and saw all three users and edited the admin user's password. When I tried to submit the changes, a blank screen comes up with the url "http://jon-vm1/open-audit/index.php/admin_user/edit_user/1" and nothing happens after that. If I go back to the edit screen, things haven't changed. Looking at the MySQL database, things haven't changed.

I also tried adding a new user and got a similar situation (blank screen, slightly different URL and no database changes).

Any ideas?


Jon Rosen

Author:  Mark [ Tue Feb 18, 2014 6:24 am ]
Post subject:  Re: Just starting... can't get new users added

Make sure you have the PHP extension "mcrypt" installed :-)

Linux - Debian and Ubuntu pre-requisites

apt-get install -q -y apache2 libapache2-mod-proxy-html libapache2-mod-php5 openssh-server php5 php5-ldap php5-mcrypt php5-mysql php5-snmp nmap snmp zip daemon wget curl sshpass screen

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group