What's on your network?
It is currently Sat Mar 24, 2018 8:13 pm

All times are UTC + 10 hours

Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Apr 08, 2010 3:26 am 

Joined: Fri Feb 08, 2008 8:05 pm
Posts: 25
First congratulations. The Openaudit is very good!
I am testing the version Oav2 and found some errors.

1 - By auditing a Windows Server 2008, the following error is reported:

audit_windows.vbs(1234, 1) (null): 0x8004100E

Commenting on lines 1232 to 1252 the error is not generated and auditing work.

2 - In the OS field name is displayed as follows:

OS Name: Microsoft® Windows Server® 2008 Standard

If I change the browser's encoding to Unicode, then it is displayed correctly. This can not be defined in HTML?

One question: how do I audit the domain?

One suggestion:

System datails, hardware detaisl, etc., can not be hidden?

Reply with quote  
PostPosted: Thu Apr 08, 2010 8:57 am 
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1944
Location: Brisbane, Australia
Win 2k8 auditing works in my current version (not released yet).
I have a script to audit a domain in my current version.

Give me a week or so...

Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.

Reply with quote  
PostPosted: Sun Apr 18, 2010 8:16 am 

Joined: Thu Feb 11, 2010 2:41 am
Posts: 19

This is something minor but I couldn't help to notice it. I was loading oav2 and I noticed that ie was giving off some warnings after I had logged in and was situated under /index.php/main/list_alerts/0
After looking at the ie warnings I saw that v_template.php line 255 has
<a href="<?=base_url()?>index.php/login/logout"><img id="logout_button" src="<?=base_url()?>theme-<?=$user_theme;?>/<?=$user_theme?>-images/28_button_logout.png" onmouseover="document.logout_button.src='<?=base_url()?>theme-<?=$user_theme;?>/<?=$user_theme?>-images/28_button_logout_over.png'" onmouseout="document.logout_button.src='<?=base_url()?>theme-<?=$user_theme;?>/<?=$user_theme?>-images/28_button_logout.png'" border="0" /></a>

I know what you are trying to accomplish but you can't use, as it is not a valid javascript implementation, in order to use an id you need to use document.getElementbyID("logout_button") or this.src

Here is what it should look like:
<a href="<?=base_url()?>index.php/login/logout"><img id="logout_button" src="<?=base_url()?>theme-<?=$user_theme;?>/<?=$user_theme?>-images/28_button_logout.png" onmouseover="this.src='<?=base_url()?>theme-<?=$user_theme;?>/<?=$user_theme?>-images/28_button_logout_over.png'" onmouseout="this.src='<?=base_url()?>theme-<?=$user_theme;?>/<?=$user_theme?>-images/28_button_logout.png'" border="0" /></a>

Bottom line, in ie the onmouse events for the Logoff button doesn't trigger correctly without making this suggested change.

Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 10 hours

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group