Registrations to Open-AudIT forums are now closed. To ask any new questions please visit Opmantek Community Questions.

Open-AudIT

What's on your network?
It is currently Sat Dec 07, 2019 6:23 am

All times are UTC + 10 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 
Author Message
PostPosted: Mon Jul 19, 2010 8:31 am 
Offline
Newbie

Joined: Sun Feb 15, 2009 6:13 am
Posts: 6
Hi,

Have moved a copy of OA to a new server (Ubuntu Linux 10.04). Contents and database easily transferred but the home page doesn't load correctly, see screen-shot.

What have I missed?

Thanks


Attachments:
hp.jpg
hp.jpg [ 87.23 KiB | Viewed 5132 times ]
Top
 Profile  
Reply with quote  
PostPosted: Wed Jul 21, 2010 9:48 am 
Offline
Newbie

Joined: Thu Jul 15, 2010 10:08 am
Posts: 6
Check your error log:
$ tail -f /var/log/apache2/error.log

Make sure apache (php, Open-AudIT) can talk to your mysql process.
1. Check the mysql connection settings in include_config.php:
$ grep -e'$mysql' /{wwwroot}/include_config.php

2. Check mysql is running:
$ ps ax |grep mysql

3. Check port 3306 is not being blocked by a firewall, or php can find the mysql socket
$ grep socket /etc/my.cnf
socket = /var/run/mysql/mysql.sock

4. Check mysql module is installed:
$ cat /{wwwroot}/info.php
<?php phpinfo(); ?>

browse to: http://myserver/info.php look for "mysql"

etc, etc, etc


Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 12, 2012 3:02 am 
Offline
Newbie

Joined: Fri Mar 21, 2008 12:31 am
Posts: 16
Location: Denver, Colorado
Having exact same problem.
In the /var/log/apache2/error.log I get the message below:


[Wed Jan 11 09:52:19 2012] [error] [client 10.182.128.22] File does not exist: /usr/share/javascript/ajax.js, referer: http://open-audit/index.php
[Wed Jan 11 09:52:19 2012] [error] [client 10.182.128.22] File does not exist: /usr/share/javascript/include.js, referer: http://open-audit/index.php


Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 12, 2012 3:19 am 
Offline
Moderator

Joined: Fri Jul 20, 2007 8:27 am
Posts: 1259
Not to belabor the obvious but check that /usr/share/javascript/ajax.js exists.


Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 12, 2012 3:37 am 
Offline
Newbie

Joined: Fri Mar 21, 2008 12:31 am
Posts: 16
Location: Denver, Colorado
I just checked that and it does not exist.
This file exists under the Open-Audit directory under the javascript folder.
So I copied the two files to where the program was looking, and it now works.

So I just have to figure out why it looks for these file under these folders when I try to use a virtualhost. It was working before without the virtualhost I created, but I did not want to use http://servername/open-audit

Now it goes to http://open-audit

Thanks for your suggestion.


Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 12, 2012 3:57 am 
Offline
Moderator

Joined: Fri Jul 20, 2007 8:27 am
Posts: 1259
You'll need to check the DocumentRoot setting for your VirtualHost config.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group