Open-AudIT

What's on your network?
It is currently Wed Jan 17, 2018 1:52 am

All times are UTC + 10 hours




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Thu Jun 19, 2014 8:36 am 
Offline
Newbie

Joined: Wed Jun 18, 2014 3:47 am
Posts: 6
I have tried to install Open-AudIT on an Ubuntu 14.01 system. I have followed all the instructions from Installing the pre-reqs on Debian and Ubuntu (old pre v1.3.1) and Linux - Installing (old pre v1.3.1). Everything seemed to work, but when I try to following the instructions to audit a PC (How to audit a single Windows computer) Iget the following error when I select the "Audit My PC" button: The requested URL /open-audit/index.php/login/audit_my_pc was not found on this server.

What do I have to do to get this URL correct?

Thank You,

David Demland


Top
 Profile  
Reply with quote  
PostPosted: Thu Jun 19, 2014 4:08 pm 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1933
Location: Brisbane, Australia
Can you log in to Open-AudIT at /open-audit/index.php/login/index/main/list_groups ?

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 20, 2014 2:24 am 
Offline
Newbie

Joined: Wed Jun 18, 2014 3:47 am
Posts: 6
When I select the Main Menu icon, after I login, I get the error message: The requested URL /open-audit/index.php/main/list_groups was not found on this server. I think something is not installed right, but I do not know where to look.


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 20, 2014 7:45 am 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1933
Location: Brisbane, Australia
You're going to need to be more specific.
Which "main menu icon"? What is the exact URL of the page this appears on?
Do you get the logon page for either Open-AudIT or Open-AudIT Enterprise appearing in your browser?
What is the URL of those pages (that are working, if any)?
Now that 1.3.2 has been released, I'd suggest you install that instead.
Download, extract to /tmp and run ./install.pl

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
PostPosted: Fri Jun 20, 2014 8:59 am 
Offline
Newbie

Joined: Wed Jun 18, 2014 3:47 am
Posts: 6
The main icon is attached. The login URL is:

http://10.72.250.172/omk/oae/login?redi ... l=/omk/oae

The main menu icon goes to this URL:

http://10.72.250.172/open-audit/index.p ... ist_groups

And the Audit My PC URL goes to:

http://10.72.250.172/open-audit/index.p ... udit_my_pc

I have Open-AudIT Enterprise and I just checked and the download page and the file that was downloaded, for Debain, was still the 1.2.1. Does the Linux x86-64 file work for Debian? What I read said that file was for Red Hat.


Attachments:
File comment: This icon shows main menu when you mouse over it.
Capture.JPG
Capture.JPG [ 10.64 KiB | Viewed 4614 times ]
Top
 Profile  
Reply with quote  
PostPosted: Sat Jun 21, 2014 7:27 am 
Offline
Newbie

Joined: Wed Jun 18, 2014 3:47 am
Posts: 6
So I just download the Linux 1.3.1 and did the upgrade. It did not seem to have a problem and now I get the attached screen when I go to the system's IP. This supports that I finally have something right because I am getting what I expected which is the community edition which is not what I had before. The problem is when I select the "Audit My PC" button and download the vbs file I get and error that the zip file is invalid. How do I fix this invalid file problem?


Attachments:
Capture.JPG
Capture.JPG [ 25.5 KiB | Viewed 4602 times ]
Capture.JPG
Capture.JPG [ 46 KiB | Viewed 4602 times ]
Top
 Profile  
Reply with quote  
PostPosted: Sat Jun 21, 2014 7:47 am 
Offline
Newbie

Joined: Wed Jun 18, 2014 3:47 am
Posts: 6
I found the problem. The vbs file is being download with a ZIP extension. When I opened the file in a text editor I found that the file was not a ZIP file, but a VB Script file. I removed the ZIP extension and ran the script and it works. How do I fix this issue?


Top
 Profile  
Reply with quote  
PostPosted: Sat Jun 21, 2014 7:55 am 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1933
Location: Brisbane, Australia
I'm guessing the vbs as zip issue is local to your PC.
It definitely is not in the code.
I just tried it from a Windows machine and it downloads the .vbs as it should.
Maybe some installed extension in your browser or proxy issue?

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
PostPosted: Mon Jun 23, 2014 10:56 am 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1933
Location: Brisbane, Australia
UPDATE.

I have been reviewing the code. Try this. On line (or there-abouts) 208 of open-audit/code_igniter/application/controllers/login.php change it from
header("Content-Type: application/zip");
to
header("Content-Type: text/vbscript");

Once you have done that, restart apache (service apache restart), and try "Audit My PC" again. Please post result as it works using application/zip for me... but things may have changed between IE versions. Thanks in advance.

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
PostPosted: Thu Jun 26, 2014 3:21 am 
Offline
Newbie

Joined: Wed Jun 18, 2014 3:47 am
Posts: 6
Sorry this has taken so ling, I have been working on different things with Open-AudIT. The code changes worked. Thank you so much.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group