Open-AudIT

What's on your network?
It is currently Wed Jan 17, 2018 5:23 pm

All times are UTC + 10 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 1 post ] 
Author Message
PostPosted: Fri Jul 30, 2010 1:45 am 
Offline
Helper

Joined: Thu Apr 15, 2010 12:28 am
Posts: 83
Hi

I have installed my OpenAudIT in to /var/www/open-audit/ and then apache complains:
Code:
[Thu Jul 29 17:27:08 2010] [error] [client 192.168.119.36] File does not exist: /var/www/images, referer: http://dkopen-audit/open-audit/

when ever i load the front page.

This patch fixes the problem on the frontpage:
Code:
dkopen-audit:/var/www/open-audit# svn diff index_data.php
Index: index_data.php
===================================================================
--- index_data.php   (revision 1245)
+++ index_data.php   (working copy)
@@ -115,7 +115,7 @@
       do
       {
          echo "<tr class='".alternate_tr_class($tr_class)."'>";
-         echo "<td><img src='../images/".$myrow['objtype']."_".$myrow['img'].".gif'></td>";
+         echo "<td><img src='./images/".$myrow['objtype']."_".$myrow['img'].".gif'></td>";
          echo "<td>".$myrow['cn']."</td>";
          $status = ($myrow["img"] == 'active') ? "Added" : "Deleted";
          echo "<td>".$status."</td>";
@@ -349,7 +349,7 @@
          echo "   <td>".ip_trans($myrow["net_ip_address"])."</td>";
          echo "   <td><a href=\"system.php?pc=".$myrow["system_uuid"]."&amp;view=summary\">".$myrow["system_name"]."</a></td>";
          echo "   <td>".return_date_time($myrow["system_timestamp"])."</td>";
-         echo "   <td><img src='../images/computer_".$myrow['ldap_status'].".gif'></td>";
+         echo "   <td><img src='./images/computer_".$myrow['ldap_status'].".gif'></td>";
          echo "</tr>";
       } while ($myrow = mysql_fetch_array($result));
       }
@@ -1471,4 +1471,4 @@
    return;
 }
 
-?>
\ No newline at end of file
+?>


But there might be one more similar problem in include_functions.php
Code:
dkopen-audit:/var/www/open-audit# grep "\.\./images" *
include_functions.php:         return "<img src='../images/user_".$myrow[$field["name"]].".gif'>";      
include_functions.php:         return "<img src='../images/computer_".$myrow[$field["name"]].".gif'>";      

The fix is similar, change ../images into .images/ but i will leave that as an exercise to the reader.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 1 post ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group