Open-AudIT
http://www.open-audit.org/phpBB3/

Unable to send xml
http://www.open-audit.org/phpBB3/viewtopic.php?f=5&t=3548
Page 1 of 1

Author:  little_crazzy [ Sat Feb 20, 2010 4:35 am ]
Post subject:  Unable to send xml

Hi users!
I can use my audit.vbs into my company but i can use it out of my company by internet.
When i run the script i have this error:

Unable to send XML to server using XMLHTTP-HTTP Response:503(service unavaliable)Error 0

THZ

Author:  A_Hull [ Sat Feb 20, 2010 7:55 am ]
Post subject:  Re: Unable to send xml

This could be for a number of reasons, I assume you are able to see the main pages.

Most likely the server is not receiving the data quickly enough, but also possibly the server is blocking the request (for security reasons perhaps, something related to the http service may limit the size of requests from non private IP address ranges, to thwart DOS attacks).

I would be cautious about exposing OpenAudit directly to the internet, and would advise using a VPN to gain access to it, to avoid external attackers attempting to gain access to sensitive information.

All of my external sites are linked by VPN, either hardware firewalls or software (OpenVPN) and there is no external world access to the OA server.

Author:  little_crazzy [ Sun Feb 21, 2010 11:13 am ]
Post subject:  Re: Unable to send xml

Thz for the reply! I am using openvpn for my remote users! and i put my OA server into my vpn .
From the client i can view the admin web or the upload web for OA but i do not know what happend !!
I have not a firewall! Into my company the OA it is ok but from vpn no!!!
THZ a lot A_HUll

Author:  A_Hull [ Mon Feb 22, 2010 10:31 pm ]
Post subject:  Re: Unable to send xml

Looks like it could be a proxy issue, do the remote sites use a proxy, if so try it with the proxy off.

Author:  little_crazzy [ Tue Feb 23, 2010 2:11 am ]
Post subject:  Re: Unable to send xml

Thz to try to help me peoble the problem was in the audit.config file.

Author:  A_Hull [ Tue Feb 23, 2010 8:03 pm ]
Post subject:  Re: Unable to send xml

Glad you found it.
:D

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/