Open-AudIT

What's on your network?
It is currently Wed Jan 17, 2018 11:25 pm

All times are UTC + 10 hours




Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
PostPosted: Thu Jan 22, 2009 5:39 am 
Offline
Newbie

Joined: Wed May 21, 2008 7:46 am
Posts: 13
I have been using Open Audit for about 6 months now- I think it is great. I have run into a problem with the printers and software inventory.
I manually audited all the machines on the network:
- some of them I audited while the user (limited permissions) was logged in
- other machines I logged in as admin and audited the system

If I remember correctly, they all showed the installed software installed on the machine. However, only those machines audited under the user login had the networked printers.

In trying to keep the audit Database more current I started to add a scheduled task to systems (run a simple .cmd file that called the audit script). However, when that runs as admin it doesn't pick up the the installed software or the networked printers!

Now the systems that had 3 pages of installed software are showing none (and all the installed programs are under uninstalled software). This creates quite a problem when trying to keep track of licenses. Furthermore, I just got some new systems in, put open-audit on them with the audit task script and they aren't showing any software at all!
Has anyone else experienced similar issues? Any idea what's going on? Suggestions for how to troubleshoot this issue or improve the auditing process?
Many thanks in advance!

_________________
Server Info: Windows 2003 Virtual Machine with XAMP
Auditing: 1 Linux + 57 XP machines
Scheduled task, calling OA from network share


Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 22, 2009 6:26 am 
The software info is read from the registry, I can't see how an admin user would fail to read it, so it might be worth experimenting with the following settings in the config file to see if they are getting sent back to the server.
verbose = "y"
online = "ie"
ie_visible = "y"
ie_auto_submit = "y"
ie_submit_verbose = "y"
I too got confused by printers, and did some work to see why my printers didn't appear.
In your example the audit job runs under the context of the admin user, so will not see any printers that exist only within the users session, ie those added by the user or in their login script, it will only see printers that have been set up as admin, ie lpt, serial, usb etc. These are processed by the script at web server, this checks the port and if thinks they are network printers they are inserted into the 'other' table, and do not show up in the PC reports. Shared printers will be picked up when the server or PC from which they are shared is audited, and inserted into the 'other' table.
Hope this helps.


Top
  
Reply with quote  
PostPosted: Thu Jan 22, 2009 6:39 am 
Be careful if you do change the config file settings, as any audit running with that config file may pop up IE windows which the user could see. If you try this I suggest you copy the scripts folder to a test PC, login as admin, start a command prompt, cd to the folder, and then call 'cscript audit.vbs'. The resultant IE window should contain the sql inserts or updates.


Top
  
Reply with quote  
PostPosted: Fri Jan 23, 2009 8:15 am 
Offline
Newbie

Joined: Wed May 21, 2008 7:46 am
Posts: 13
Many thanks for that helpful tip about the settings to play with. Seeing the SQL was very cool. The page that pops up shows: "Software Audit: y" but I don't see it performing any SQL actions related to software...

To try to troubleshoot the issue I attempted to delete a system via the web administration and it failed! It says "Query failed at insert stage. services"

Has anyone else seen anything like this?
Many thanks!


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group