Open-AudIT

What's on your network?
It is currently Wed Jan 24, 2018 11:54 am

All times are UTC + 10 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Thu Feb 02, 2017 5:55 am 
Offline
Contributor
User avatar

Joined: Thu Mar 02, 2006 4:41 am
Posts: 186
Location: Massachusetts
here is my enviro:

You are running version 1.12.10 of Open-AudIT.
Your Host is: VENGOA1, and it's OS is Microsoft Windows Server 2008 R2 Standard.
Your database platform is mysql (version 5.1.41).
Your web server is Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 .
Your PHP version is 5.3.1 and it's running in timezone America/New_York.


here is the error I recently ran into. Guess I haven't tries any queries in some time or I would have noticed quicker

A Database Error Occurred

Error Number: 1054

Unknown column 'system.man_type' in 'field list'

/* M_oa_report::get_report */ SELECT system.man_type, system.system_id, system.hostname, date(system.first_timestamp) as first_seen, date(system.last_seen) as last_seen, system.last_seen_by, system.man_model, system.man_manufacturer, system.man_serial, system.man_owner, oa_location.location_name, system.os_family, oa_org.org_name FROM system LEFT JOIN oa_location ON system.man_location_id = oa_location.location_id LEFT JOIN oa_group_sys ON system.system_id = oa_group_sys.system_id LEFT JOIN oa_org ON system.man_org_id = oa_org.org_id WHERE oa_group_sys.group_id = @group AND man_type = '0' GROUP BY system.system_id ORDER BY system.hostname, first_seen, man_manufacturer, man_model, man_serial

Filename: C:\xampplite\open-audit\code_igniter\system\database\DB_driver.php

Line Number: 330


update: just noticed multiple errors, depending on what I select in QUERIES menu

Error Number: 1054

Unknown column 'system.system_id' in 'field list'

/* M_oa_report::get_report */ SELECT system.system_id, system.hostname, system.man_owner, system.man_ip_address, floor(system.pc_memory / 1024) AS pc_memory, processor.description, system.man_model, system.icon, date(system.last_seen) AS last_seen, system.last_seen_by, system.man_owner, system.man_os_family, windows.client_site_name, windows.user_name, oa_location.name FROM system LEFT JOIN oa_group_sys ON (system.system_id = oa_group_sys.system_id) LEFT JOIN windows ON (system.system_id = windows.system_id AND windows.current = 'y') LEFT JOIN processor ON (processor.system_id = system.system_id AND processor.current = 'y') LEFT JOIN oa_location ON (system.man_location_id = oa_location.id) WHERE oa_group_sys.group_id = @group AND man_type = 'computer' AND man_class != 'server'

Filename: C:\xampplite\open-audit\code_igniter\system\database\DB_driver.php

Line Number: 330

_________________
Server Info: running on a CentOS 7 vm
OA Version: 2.0.6 @ 500 devices


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 02, 2017 7:05 am 
Offline
Moderator

Joined: Fri Jul 20, 2007 8:27 am
Posts: 1229
Are these custom queries? The database has gone through a bunch of table and field renames lately. Man_* fields are gone, system_id is id, etc. If they're built in queries you could disable the query and enable again to get updated query definitions. Otherwise you'll need to manually fix stuff.


Top
 Profile  
Reply with quote  
PostPosted: Tue Feb 07, 2017 7:34 am 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1935
Location: Brisbane, Australia
Release Notes are your friend :-)
https://community.opmantek.com/display/OA/Release+Notes

This specific issue is covered in 1.12.8.
https://community.opmantek.com/display/OA/Release+Notes+for+Open-AudIT+v1.12.8

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
PostPosted: Wed Feb 08, 2017 12:29 am 
Offline
Contributor
User avatar

Joined: Thu Mar 02, 2006 4:41 am
Posts: 186
Location: Massachusetts
I've never used a custom report or query, the issue was just some old out of the box queries, which I've deleted. Thank you!

_________________
Server Info: running on a CentOS 7 vm
OA Version: 2.0.6 @ 500 devices


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group