Open-AudIT

What's on your network?
It is currently Wed Jan 17, 2018 3:24 pm

All times are UTC + 10 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sat Aug 20, 2016 3:26 am 
Offline
Contributor
User avatar

Joined: Thu Mar 02, 2006 4:41 am
Posts: 179
Location: Massachusetts
When attempting to do a "SNMP scan" for an esxi host I got an error "Parse error: syntax error, unexpected T_LOGICAL_AND, expecting ')' in line 242 c:\xampplite\open-audit\code_igniter\application\controllers\admin_system.php

this is line 242
Quote:
if (!empty($credential->type and $credential->type == 'snmp')) {


Here is the fix
Quote:
if (!empty($credential->type) and $credential->type == 'snmp') {


I moved a close from the end, to after the first "type"

_________________
Server Info: running on a CentOS 7 vm
OA Version: 2.0.6 @ 500 devices


Top
 Profile  
Reply with quote  
PostPosted: Sat Aug 20, 2016 5:30 am 
Offline
Newbie

Joined: Tue Aug 16, 2016 10:50 pm
Posts: 6
Thanks!


Top
 Profile  
Reply with quote  
PostPosted: Sun Aug 21, 2016 11:17 am 
Offline
Site Admin
User avatar

Joined: Mon Jun 07, 2004 11:48 am
Posts: 1933
Location: Brisbane, Australia
Fixed, thanks for the report. It's in 1.12.8.1.

_________________
Support and Development hours available from Opmantek.
Please consider a purchase to help make Open-AudIT better for everyone.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group