Open-AudIT
http://www.open-audit.org/phpBB3/

Problems Upgrading to 1.12
http://www.open-audit.org/phpBB3/viewtopic.php?f=20&t=6512
Page 1 of 1

Author:  stephend [ Wed Feb 17, 2016 7:47 pm ]
Post subject:  Problems Upgrading to 1.12

Hi

I've run into problems upgrading from 1.8.4 to 1.12. Hope someone can help please ?

I downloaded the update (Windows), ran it on the server. All went OK. Logged onto OpenAudit and updated the database, no problems reported.

I then edited the new audit_windows.vbs script and tried it on my workstation, but it reports the following error when trying to upload to the server

<body>
<div id="container">
<h1>A Database Error Occurred</h1>
<p>Error Number: 1146</p><p>Table 'openaudit.sys_sw_software' do
esn't exist</p><p>SELECT system_id FROM system WHERE system_id = '1' AND system_
id in ( SELECT distinct(system.system_id) FROM sys_sw_software, system WHERE sys
_sw_software.system_id = system.system_id AND software_name LIKE '%Mozilla Firef
ox%' AND system.man_status = 'production' AND sys_sw_software.timestamp = system
.timestamp )</p><p>Filename: C:\xampplite\open-audit\code_igniter\system\databas
e\DB_driver.php</p><p>Line Number: 330</p> </div>
</body>

I started to check through what else might be broken and came across some weird problems.

1) Many groups are broken - but a lot of these have been customised and the database schema has changed and I was querying on tables that no longer exist, fair enough. Then I came across a group that worked OK, but it was querying sys_sw_software, the table that the error above says doesn't exist. I took a copy of the XML for the group that worked and tried to import it again with a different name - it errored and said that sys_sw_software doesn't exist. But the original group still works..........????

2) I went to Admin, Groups, Add Group and checked to see what tables were available in the Group Selection menu. Only the following are showing
sys_hw_network_card_ip
sys_man_additional_fields
sys_man_additional_fields_data
sys_man_attachment
sys_man_invoice
sys_man_invoice_line
sys_man_notes
system

3) Checked the database schema by going to Admin, Database, Export a Database Table. I can see all the renamed tables such as bios, disk, memory, software etc, but many of them seem to be inaccessible. If I try to export them I receive a Page Can't Be Displayed error (software being one of those that is broken)

Can anyone help please ? I didn't spot any specific upgrade procedures in the release notes and this method has always worked before. Can it be rescued, or am I going to have to restore the virtual machine from backup


Thanks
STEVE

Author:  Mark [ Wed Feb 17, 2016 10:01 pm ]
Post subject:  Re: Problems Upgrading to 1.12

Hi Stephen,

Everything you've posted sounds as it should be - with the exception of the table export. I'll look into that. UPDATE, just checked and I can export the tables just fine.

Admin -> Groups -> Add Group is definitely broken though. Thanks for reporting it. I'll ensure it's fixed for the next release.

sys_sw_software has indeed been renamed to software (as have the others you've found).

I have replaced all group and report definitions that ship with Open-AudIT and yours should have been replaced by the upgrade procedure. Any custom groups or reports will not have been upgraded and you should have seen a message when you updated the DB.

This was all covered in the release notes - https://community.opmantek.com/display/OA/Release+Notes+for+Open-AudIT+v1.10.

We should definitely be able to rescue this. Absolute worst case - ship me a copy of the DB and I'll fix it by hand. But let's cross that bridge only if we need to :-)

Author:  stephend [ Wed Feb 17, 2016 10:11 pm ]
Post subject:  Re: Problems Upgrading to 1.12

Thanks Mark - After I posted this I had to run a restore as I needed OpenAudit back, but I restored the VM as a copy, so the broken upgrade is still there, but currently shutdown.

Sounds like I will need to wait until the next release as we use the group admin wizard quite a bit. Next time I will keep a copy of the database update report as it sounds like something went wrong that I missed.

I'll see what happens when I next upgrade


STEVE

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/