Open-AudIT

What's on your network?
It is currently Wed Jan 24, 2018 9:53 am

All times are UTC + 10 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Fri Dec 18, 2015 12:05 am 
Offline
Newbie
User avatar

Joined: Wed Nov 12, 2014 6:57 pm
Posts: 14
Location: Frankfurt a.M., Germany
At the moment you lose any custom sort order when the page does its auto refresh to keep the session.
Is there any way to prevent this from happening?

_________________
Server Info:
OS : Ubuntu 14.04
Auditing: ~ 500 machines (35 Windows Server, 440 Linux Server)
LDAP: not yet
Version: Open-AudIT Version 1.8.4


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 18, 2015 10:05 am 
Offline
Moderator

Joined: Fri Jul 20, 2007 8:27 am
Posts: 1229
I took a quick stab at this and was able to get something to work but it did cause visual side affects that I didn't spend the time to track down.

What I did:
Download jquery.tablesorter.min.js, jquery.tablesorter.pager.js and jquery.tablesorter.widgets.js from here. Widgets is the new important bit.
Copy the files to open-audit\theme-tango\tango-files\jquery\css\humanity overwriting the existing two tablesorter files.
Edit "code_igniter\application\views\theme-tango\v_template.php"
Add the following to the other <script> lines at the top:
Code:
<script type="text/javascript" src="<?php echo $oa_theme_files; ?>/jquery/js/jquery.tablesorter.widgets.js"></script>

Change the tablesorter line around line 120:
Code:
$("table").tablesorter({cancelSelection: false, widthFixed: true, sortList: [[<?php echo $sortcolumn?>,0],[<?php echo $sortcolumn?>,0]], widgets: ['saveSort', 'zebra'] })
Adding saveSort to widgets.

See what happens. It mostly worked for me but clobbered the ascending/descending sort indicators. Need to fix the CSS or something.


Top
 Profile  
Reply with quote  
PostPosted: Tue Jan 05, 2016 7:38 pm 
Offline
Newbie
User avatar

Joined: Wed Nov 12, 2014 6:57 pm
Posts: 14
Location: Frankfurt a.M., Germany
Thanks a lot jpa, will have a look at it as soon as I migrate our Open-Audit installation to a new server.

On a side note - I did not get an email notification from the forum when your reply was posted...

_________________
Server Info:
OS : Ubuntu 14.04
Auditing: ~ 500 machines (35 Windows Server, 440 Linux Server)
LDAP: not yet
Version: Open-AudIT Version 1.8.4


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group