Open-AudIT
http://www.open-audit.org/phpBB3/

v1.82 BASHPID not available in bash versions smaller than 4
http://www.open-audit.org/phpBB3/viewtopic.php?f=20&t=6462
Page 1 of 1

Author:  FranzXaver [ Wed Sep 23, 2015 6:42 pm ]
Post subject:  v1.82 BASHPID not available in bash versions smaller than 4

The new audit_linux.sh script in version 1.82 tries to read the environment variable $BASHPID, this will fail on bash versions smaller than 4.
A workaround for older bash versions:

Code:
if [ -z "$BASHPID" ]; then
        script_pid="$(sh -c 'echo $PPID')"
else
        script_pid="$BASHPID"
fi


Update: I opened a JIRA issue for this, hope this is ok: https://support.opmantek.com/browse/OA-245

Author:  Mark [ Thu Sep 24, 2015 9:19 am ]
Post subject:  Re: v1.82 BASHPID not available in bash versions smaller tha

Thanks very much Franz.
I have integrated the code and it will be in the next release :-)

Page 1 of 1 All times are UTC + 10 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/